Vikunja veans before 2.7.1 contains a protocol downgrade vulnerability in serverCandidates that allows on-path
Source GCVE Database
Not known to be exploited · CVSS 7.6 High : upgrade to 2.7.1 soon.
Data as of 8 Nov 2026, 07:02 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.6 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.8 |
- Patch
- Available – fixed in 2.7.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade vikunja to 2.7.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| go-vikunjavikunja | Affected
| Fixed in
|
Govikunjapkg:golang/vikunjaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should avoid using vulnerable versions and consider network-level protections to prevent protocol downgrade attacks.
Description
Vikunja veans versions before 2.7.1 have a protocol downgrade vulnerability in the serverCandidates component. This flaw allows on-path attackers to force the use of plain HTTP instead of HTTPS during initialization and login. By blocking HTTPS ports, attackers can cause the client to accept unverified HTTP responses, enabling interception of sensitive data such as passwords, TOTP codes, and bot tokens, as well as cleartext API traffic.