Skip to main content
VulnerabilityPublished

CVE-2025-59933: vips vulnerabilities

Affects vipsSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 8.2.2-1ubuntu0.1~esm1 : patch vips soon.

Data as of 4 Nov 2026, 04:01 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 8.2.2-1ubuntu0.1~esm1, 8.4.5-1ubuntu0.1~esm2, 8.9.1-2ubuntu0.1~esm2 +3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu Pro 26.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • <8.18.0-1ubuntu0.1~esm2
Fixed in
  • 8.18.0-1ubuntu0.1~esm2
Ubuntu Pro 24.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <8.15.1-1.1ubuntu0.1~esm2
  • =8.15.1-1build1
Fixed in
  • 8.15.1-1.1ubuntu0.1~esm2
Ubuntu Pro 22.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/jammyOther threatsAffected
  • <8.12.1-1ubuntu0.1~esm3
Fixed in
  • 8.12.1-1ubuntu0.1~esm3
Ubuntu Pro 20.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/focalOther threatsAffected
  • <8.9.1-2ubuntu0.1~esm2
Fixed in
  • 8.9.1-2ubuntu0.1~esm2
Ubuntu Pro 18.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps/bionicOther threatsAffected
  • <8.4.5-1ubuntu0.1~esm2
Fixed in
  • 8.4.5-1ubuntu0.1~esm2
Ubuntu Pro 16.04 LTSvipspkg:deb/ubuntu/vips?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • <8.2.2-1ubuntu0.1~esm1
Fixed in
  • 8.2.2-1ubuntu0.1~esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should update libvips to the patched versions provided by Ubuntu for their respective LTS releases. The patched versions include 8.2.2-1ubuntu0.1~esm1, 8.4.5-1ubuntu0.1~esm2, 8.9.1-2ubuntu0.1~esm2, 8.12.1-1ubuntu0.1~esm3, and 8.15.1-1.1ubuntu0.1~esm2 among others. Applying these updates will remediate the vulnerabilities. Standard system updates or Ubuntu Pro with Extended Security Maintenance (ESM) can be used to obtain these fixes.

Description

Multiple vulnerabilities were discovered in libvips affecting various Ubuntu LTS releases. These include incorrect handling of PDF files, integer overflows in image dimension calculations, improper validation of EXIF tags, and errors processing TIFF, Radiance, and PPM images. The issues could lead to denial of service, information disclosure, or potentially arbitrary code execution. Fixes are available in updated libvips package versions for affected Ubuntu releases.

References

Community reviews

Loading reviews…