CVE-2026-113723: virtualenv · Bash prompt values can change meaning under older compatibility modes
Affects hatchSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 1.18.1_2 or 1.6.2 soon.
Data as of 27 Oct 2026, 23:27 UTC
- Patch
- Available – fixed in 1.18.1_2, 1.6.2
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade hatch to 1.18.1_2 or 1.6.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewhatchpkg:brew/hatchOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should upgrade virtualenv to version 1.6.2 or later, or 1.18.1_2 or later, where the issue is fixed. The fix changes how the PS1 prompt variable is assigned to prevent execution of attacker-controlled prompt text. Users should avoid running older versions of virtualenv with affected shells in compatibility modes that expose this issue. No additional mitigation is required if the environment is created and activated using patched versions.
Description
CVE-2026-113723 is a vulnerability in virtualenv's bash activation prompt handling where attacker-controlled prompt text can be interpreted as executable shell syntax under certain older bash compatibility modes (4.2 and lower) or when using dash shell. This can lead to command execution when the environment is activated and the prompt is drawn. The issue arises because the prompt string assigned to PS1 is expanded twice by the shell, and some code paths do not properly escape or sanitize the prompt text. The vulnerability affects virtualenv versions from 1.2.0 up to but not including 1.6.2 and 1.9.3 up to but not including 1.18.1_2. A fix is available in versions 1.6.2 and 1.18.1_2.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-6w3r-xr62-4xcp (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113723 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3418 (opens in a new tab)
- github.com/pypa/virtualenv/commit/5f48d711731311428aebfae61d46957762155b22 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)