Skip to main content
VulnerabilityPublished Updated

CVE-2026-102930: virtualenv · Downloaded seed wheels (pip/setuptools) are not integrity-checked before use

Affects hatchSource GCVE Database

0
Authoritative record:CVE-2026-102930· High 7.7

Not known to be exploited · CVSS 7.7 High : upgrade to 1.18.1_1 or 1.6.2 soon.

Data as of 27 Oct 2026, 23:28 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.18.1_1, 1.6.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade hatch to 1.18.1_1 or 1.6.2.

Affected software

ProductAffectedFixed in
Homebrewhatchpkg:brew/hatchOther threatsAffected
  • >=1.2.0 <1.6.2
  • >=1.9.3 <1.18.1_1
Fixed in
  • 1.6.2
  • 1.18.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade virtualenv to version 1.6.2 or later, or 1.18.1_1 or later, where the integrity check for downloaded wheels is implemented. Users relying on custom package indexes should be aware that the integrity check is skipped in those cases, so ensure the security of private indexes. No additional mitigation is required once patched.

Description

A vulnerability in virtualenv versions >=1.2.0 <1.6.2 and >=1.9.3 <1.18.1_1 allows downloaded pip and setuptools wheels to be used without integrity verification. This flaw could enable an attacker who controls or intercepts the package source to substitute malicious wheels, which virtualenv would cache and use in new environments without warning. The issue is fixed in versions 1.6.2 and 1.18.1_1 by verifying the SHA256 checksum of downloaded wheels against PyPI's public JSON API, except when a custom index is configured.

References

Community reviews

Loading reviews…