Skip to main content
VulnerabilityPublished Updated

CVE-2026-113722: virtualenv · Generated POSIX console launchers interpret destination paths as shell syntax

Affects hatchSource GCVE Database

0
Authoritative record:CVE-2026-113722· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 1.18.1_2 or 1.6.2 soon.

Data as of 27 Oct 2026, 23:27 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.18.1_2, 1.6.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade hatch to 1.18.1_2 or 1.6.2.

Affected software

ProductAffectedFixed in
Homebrewhatchpkg:brew/hatchOther threatsAffected
  • >=1.2.0 <1.6.2
  • >=1.9.3 <1.18.1_2
Fixed in
  • 1.6.2
  • 1.18.1_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in virtualenv versions 1.6.2 and 1.18.1_2. Users should upgrade to these or later versions to prevent shell command injection via the interpreter path in POSIX console launchers. The vendor advisory notes that pip's vendored distlib code may still produce vulnerable wrappers during pip install or upgrade, so users should ensure pip is also updated accordingly. No additional mitigation is required if patched versions are used.

Description

A vulnerability in virtualenv allows attacker-controlled destination paths to be interpreted as shell syntax by generated POSIX console launchers. This occurs because the interpreter path is not properly escaped in shell wrappers, enabling shell expansions like $(...) to execute commands when the launcher is run. The issue affects POSIX console scripts generated by the app-data seeder or pip when the interpreter path requires a shell wrapper. Windows executable launchers are not affected. The vulnerability was introduced in virtualenv 20.0.2 and fixed in versions 1.6.2 and 1.18.1_2.

References

Community reviews

Loading reviews…