CVE-2026-113717: virtualenv · Pip seeding with download omits wheel digest verification
Affects pipenvSource GCVE Database
Not known to be exploited · CVSS 2.3 Low : upgrade to 2026.10.1 when convenient.
Data as of 27 Oct 2026, 06:57 UTC
- Patch
- Available – fixed in 2026.10.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pipenv to 2026.10.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpipenvpkg:brew/pipenvOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in virtualenv version 2026.10.1 that fixes this issue by performing wheel acquisition and digest verification before invoking pip with index lookup disabled. Users should upgrade to version 2026.10.1 or later. If upgrading is not immediately possible, avoid using the combination of --seeder pip and --download options or ensure that the configured package index is fully trusted. No other mitigations are indicated by the vendor advisory.
Description
CVE-2026-113717 is a vulnerability in virtualenv's pip seeder when used with the --download option. The issue arises because the pip seeder downloads bundled wheels with download=False, skipping virtualenv's wheel digest verification. This allows an attacker controlling a package index to serve a modified pip wheel that bypasses the SHA-256 digest check, potentially installing tampered code. The vulnerability requires both the --seeder pip and --download options to be enabled. A fix is available in virtualenv version 2026.10.1.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-cx28-75q4-x26q (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113717 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3430 (opens in a new tab)
- github.com/pypa/virtualenv/commit/7babec66e043e1cc8bc66869a063653898719d96 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)