CVE-2026-113718: virtualenv · Xonsh activation literals depend on the script decoding codec
Affects pipenvSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2026.10.1 soon.
Data as of 27 Oct 2026, 06:43 UTC
- Patch
- Available – fixed in 2026.10.1
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pipenv to 2026.10.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpipenvpkg:brew/pipenvOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in virtualenv version 2026.10.1 that fixes the quoting mechanism in the xonsh activation script generator to escape non-ASCII characters properly. Users should upgrade to version 2026.10.1 or later to mitigate this vulnerability. Existing activation scripts (activate.xsh) should be regenerated after applying the fix. No other mitigations are specifically required.
Description
CVE-2026-113718 is a vulnerability in virtualenv's xonsh activation script where attacker-controlled prompt text can become executable code due to encoding mismatches. The issue arises when the activation script is read using legacy multibyte encodings like GBK or Big5 instead of UTF-8, causing backslash escapes to be misinterpreted and allowing injected code execution during environment activation. This affects POSIX xonsh activation scripts and requires an attacker to control the prompt or destination argument passed to virtualenv and a user to source the generated activation script. The vulnerability is fixed in virtualenv version 2026.10.1.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-394h-qwmc-48pf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113718 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3432 (opens in a new tab)
- github.com/pypa/virtualenv/commit/e5fc2e6e189a877ff559af288919e3525d13e5e0 (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)