CVE-2026-113715: virtualenv · Venv configuration readback can reinterpret path boundaries
Affects pdmSource GCVE Database
Not known to be exploited · CVSS 2.0 Low : upgrade to 2.29.3 or 2.9.3_2 when convenient.
Data as of 27 Oct 2026, 21:12 UTC
- Patch
- Available – fixed in 2.29.3, 2.9.3_2
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pdm to 2.29.3 or 2.9.3_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewpdmpkg:brew/pdmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in virtualenv versions 20.9.3_2 and 20.29.3. Users should upgrade to these or later versions to mitigate this vulnerability. The fix rejects line-boundary characters in destination paths before environment creation and rebuilds the final configuration from selected settings. No additional action is required once the environment is created with a patched version.
Description
A vulnerability in virtualenv's venv creator configuration readback allows specially crafted destination paths containing Unicode line boundary characters (e.g., U+2028) to inject additional configuration keys into the pyvenv.cfg file. This can alter environment settings such as the 'home' directory and 'include-system-site-packages' flag, potentially changing which standard library files the interpreter loads and weakening environment isolation. The issue affects virtualenv versions from 20.2.1 up to but not including 20.9.3_2 and from 20.12.3 up to but not including 20.29.3. A fix is available in versions 20.9.3_2 and 20.29.3.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-qmx5-4p3x-wvqf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-113715 (opens in a new tab)
- github.com/pypa/virtualenv/pull/3426 (opens in a new tab)
- github.com/pypa/virtualenv/commit/b0008a58885ded9227faf8f910c6c402712c750a (opens in a new tab)
- github.com/pypa/virtualenv (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)