Skip to main content
VulnerabilityPublished

CVE-2026-47781: pdm · Untrusted Functionality Inclusion

Affects pdmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.4 High : upgrade to 2.27.0 soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.27.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade pdm to 2.27.0.

Affected software

ProductAffectedFixed in
pdm-projectpdmAffected
  • <2.27.0
Fixed in
  • 2.27.0
PyPIpdmpkg:pypi/pdmOther threatsAffected
  • <=2.26.9
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pdm to version 2.27.0 or later, where this vulnerability is fixed. Until then, avoid running pdm commands in untrusted repository checkouts or environments where attacker-controlled files may exist. Patch status is confirmed fixed in version 2.27.0.

Description

PDM, a Python package and dependency manager, versions up to and including 2.26.9 automatically load project-local plugins from a .pdm-plugins directory during initialization. This behavior allows an attacker-controlled file in an untrusted repository checkout to execute arbitrary Python code before any command is parsed. The vulnerability arises because the load_plugins() function runs during Core.init() and adds .pdm-plugins via site.addsitedir(), which processes .pth files and executes import lines immediately. This code execution occurs with the privileges of the user running pdm, affecting even benign commands like pdm --version. The issue is fixed in version 2.27.0.

References

Community reviews

Loading reviews…