Skip to main content
VulnerabilityPublished

CVE-2026-113715: virtualenv · Venv configuration readback can reinterpret path boundaries

Affects hatchSource GCVE Database

0
Authoritative record:CVE-2026-113715· Low 2.0

Not known to be exploited · CVSS 2.0 Low : upgrade to 1.18.1_2 when convenient.

Data as of 27 Oct 2026, 21:12 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.18.1_2
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade hatch to 1.18.1_2.

Affected software

ProductAffectedFixed in
Homebrewhatchpkg:brew/hatchOther threatsAffected
  • >=1.9.3 <1.18.1_2
Fixed in
  • 1.18.1_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in virtualenv version 1.18.1_2 that rejects line-boundary characters in the destination path before environment creation and safely rebuilds the configuration. Users should upgrade to version 1.18.1_2 or later. No additional mitigation is required if the patched version is used. The vulnerability only affects environments created with the venv creator, so avoiding this creator or using the built-in creator path also avoids the issue.

Description

CVE-2026-113715 is a low-severity vulnerability in virtualenv's venv creator configuration readback. The issue arises because virtualenv reads the standard library's pyvenv.cfg file using splitlines(), which treats certain Unicode line boundary characters (e.g., U+2028) as line breaks. An attacker controlling the destination path passed to the venv creator can inject configuration keys by including such characters, causing virtualenv to merge malicious keys into its configuration. This can alter the environment's home path and enable inclusion of system site packages, weakening isolation. The vulnerability affects virtualenv versions from 1.9.3 up to but not including 1.18.1_2. A fix is available in version 1.18.1_2 that rejects line-boundary characters before creation and rebuilds the configuration safely.

References

Community reviews

Loading reviews…