Skip to main content
CVE-2026-112945VulnerabilityPublished Updated

Vite: Prior to 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3, applications using custom middleware are vulnerable when they

Affects viteSource GCVE Database

0
Authoritative record:CVE-2026-112945· Low 2.1

Not known to be exploited · CVSS 2.1 Low.

Data as of 28 Oct 2026, 23:28 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10vitepkg:deb/ubuntu/vite?arch=source&distro=stonkingOther threatsAffected
  • =1.4-6
  • =1.4-6build1
Fixed in–
Ubuntu 26.04 LTSvitepkg:deb/ubuntu/vite?arch=source&distro=resoluteOther threatsAffected
  • 1.4-1 – 1.4-6
4 affected builds
Fixed in–
Ubuntu 24.04 LTSvitepkg:deb/ubuntu/vite?arch=source&distro=nobleOther threatsAffected
  • =1.2+svn+git4.c6c0ce7-8
  • =1.2+svn+git4.c6c0ce7-8build1
  • =1.2+svn+git4.c6c0ce7-8build2
Fixed in–
Ubuntu 22.04 LTSvitepkg:deb/ubuntu/vite?arch=source&distro=jammyOther threatsAffected
  • =1.2+svn+git4.c6c0ce7-3
  • =1.2+svn+git4.c6c0ce7-4
Fixed in–
Ubuntu 20.04 LTSvitepkg:deb/ubuntu/vite?arch=source&distro=focalOther threatsAffected
  • =1.2+svn1430-6
  • =1.2+svn1430-6build1
Fixed in–
Ubuntu 18.04 LTSvitepkg:deb/ubuntu/vite?arch=source&distro=bionicOther threatsAffected
  • =1.2+svn1430-5
  • =1.2+svn1430-6
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Vite to versions 6.4.4, 7.3.7, 8.1.6, 8.2.4, or 8.3.3 or later where this vulnerability is fixed. No other mitigation is indicated or required by the vendor advisory.

Description

Vite versions prior to 6.4.4, 7.3.7, 8.1.6, 8.2.4, and 8.3.3 have a vulnerability affecting applications using custom middleware that pass an unchanged browser request URL to server.transformIndexHtml. This flaw allows an attacker to craft a development-server page that causes the victim's browser to fetch and execute an attacker-controlled module, potentially exposing sensitive page data or enabling critical actions. The issue is fixed in the specified versions.

References

Community reviews

Loading reviews…