CVE-2025-21566: Incorrect Permissions
Source GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 9.1.1 when convenient.
Data as of 30 Oct 2026, 01:04 UTC
Thin evidence
One scorer or none| CNA (oracle) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 9.1.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade com.oracle/mysql-server to 9.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavencom.oracle/mysql-serverpkg:maven/com.oracle/mysql-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Oracle has released security patches for this vulnerability in the January 2025 Critical Patch Update. Users should apply the relevant patches promptly to remediate the issue. Oracle strongly recommends staying on actively supported versions and applying Critical Patch Updates without delay to prevent exploitation. No alternative mitigations or workarounds are specified.
Description
A vulnerability in the Oracle MySQL Server's Optimizer component affects versions 9.1.0 and prior. This flaw allows a low-privileged attacker with network access to cause a denial of service by hanging or crashing the MySQL Server. The vulnerability has a CVSS 3.1 base score of 6.5, indicating a medium severity impact focused on availability.