CVE-2025-66034: Weasyprint · fontTools is Vulnerable to Arbitrary File Write and XML injection in fontTools.varLib
Affects weasyprintSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 66.0_2 when convenient.
Data as of 26 Oct 2026, 17:57 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 66.0_2
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade weasyprint to 66.0_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewweasyprintpkg:brew/weasyprintOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in fontTools.varLib version 66.0_2. Users should upgrade to version 66.0_2 or later to remediate this vulnerability. No additional mitigation actions are required beyond applying the official fix.
Description
CVE-2025-66034 is an arbitrary file write vulnerability in the fontTools.varLib component used by WeasyPrint. It arises from unsanitized filename handling and XML injection in .designspace files, allowing attackers to write files to arbitrary filesystem locations and inject malicious content. This can lead to remote code execution without elevated privileges and potential privilege escalation by overwriting critical system files. The vulnerability affects fontTools.varLib versions >=61.0 and <66.0_2 and has been fixed in version 66.0_2.
References
- github.com/fonttools/fonttools/security/advisories/GHSA-768j-98cg-p3fv (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-66034 (opens in a new tab)
- github.com/fonttools/fonttools/commit/a696d5ba93270d5954f98e7cab5ddca8a02c1e32 (opens in a new tab)
- github.com/fonttools/fonttools (opens in a new tab)