Weasyprint: Scrapy is vulnerable to a denial of service (DoS) attack due to flaws in brotli decompression
Affects weasyprintSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 66.0_1 soon.
Data as of 26 Oct 2026, 17:57 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 66.0_1
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade weasyprint to 66.0_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewweasyprintpkg:brew/weasyprintOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Weasyprint version 66.0_1 that addresses this vulnerability by incorporating security enhancements from brotli v1.2.0. Users should upgrade to version 66.0_1 or later to mitigate this issue.
Description
Scrapy versions up to 2.13.3 are vulnerable to a denial of service (DoS) attack due to a flaw in the brotli decompression implementation. The existing protection against decompression bombs does not mitigate the brotli variant, allowing remote servers to cause clients to crash by consuming excessive memory during decompression. This vulnerability is fixed in version 66.0_1 of Weasyprint.
References
- nvd.nist.gov/vuln/detail/CVE-2025-6176 (opens in a new tab)
- github.com/google/brotli/issues/1327 (opens in a new tab)
- github.com/google/brotli/issues/1375 (opens in a new tab)
- github.com/google/brotli/pull/1234 (opens in a new tab)
- github.com/scrapy/scrapy/pull/7134 (opens in a new tab)
- github.com/google/brotli/commit/67d78bc41db1a0d03f2e763497748f2f69946627 (opens in a new tab)
- github.com/scrapy/scrapy/commit/14737e91edc513967f516fc839cc9c8a4f8d91da (opens in a new tab)
- github.com/google/brotli (opens in a new tab)
- github.com/google/brotli/releases/tag/v1.2.0 (opens in a new tab)
- huntr.com/bounties/2c26a886-5984-47ee-a421-0d5fe1344eb0 (opens in a new tab)