Skip to main content
CVE-2026-121993VulnerabilityPublished

wePOS (Point Of Sale for WooCommerce) before 2.0.3 contains a missing authorization vulnerability in the

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121993· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.0.3 when convenient.

Data as of 4 Nov 2026, 16:43 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.14.3
Patch
Available – fixed in 2.0.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade wePOS – Point Of Sale (POS) for WooCommerce & Dokan to 2.0.3.

Affected software

ProductAffectedFixed in
wedevswePOS – Point Of Sale (POS) for WooCommerce & DokanAffected
  • >=1.2.6 <2.0.3
Fixed in
  • 2.0.3
GitHubwePOS – Point Of Sale (POS) for WooCommerce & Dokanpkg:github/wePOS – Point Of Sale (POS) for WooCommerce & DokanOther threatsAffected
  • >=1.2.6 <2.0.3
Fixed in
  • 2.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in wePOS version 2.0.3. Users should upgrade to version 2.0.3 or later to remediate this vulnerability. No other mitigation guidance is provided or necessary as the issue is resolved by the patch.

Description

wePOS (Point Of Sale for WooCommerce) versions before 2.0.3 have a missing authorization vulnerability in the REST API endpoint wepos/v1/payment/process. This flaw allows authenticated vendor-level users with the publish_shop_orders capability to mark arbitrary orders as paid and completed by submitting another order's ID. Exploitation triggers the order completion lifecycle, including stock reduction and granting paid-order access, without actual payment.

References

Community reviews

Loading reviews…