Skip to main content
CVE-2026-116244VulnerabilityPublished

When a pgAdmin 4 connection was not meant to use a Kerberos user's delegated credentials, pgAdmin removed KRB5CCNAME

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-116244· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade to 9.19 soon.

Data as of 30 Oct 2026, 23:28 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.18.2
CNA (PostgreSQL)CVSS 4.07.1
Patch
Available – fixed in 9.19
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade pgAdmin 4 to 9.19.

Affected software

ProductAffectedFixed in
pgadmin.orgpgAdmin 4Affected
  • <9.19
Fixed in
  • 9.19
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threatsAffected
  • <9.19
Fixed in
  • 9.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pgAdmin 4 to version 9.19 or later where this issue is fixed. The fix includes isolating Kerberos credential environment variables per connection and enforcing require_auth settings with libpq 16 or later. Ensure libpq is updated to version 16 or newer to support the require_auth settings. No other mitigations are indicated by the vendor advisory.

Description

A vulnerability in pgAdmin 4 before version 9.19 allowed unintended use of a Kerberos service account's credentials for GSSAPI authentication. When a connection was not meant to use a Kerberos user's delegated credentials, pgAdmin removed the KRB5CCNAME environment variable, causing the Kerberos library to fall back to the default credential cache of the operating system account running pgAdmin. This allowed any user to connect as the service account's Kerberos principal regardless of the username provided. The issue also affected Windows SSPI and psql started with pgAdmin's environment. The fix involves isolating Kerberos credential environment variables per connection and requiring updated libpq 16 or later for proper authentication enforcement.

References

Community reviews

Loading reviews…