Skip to main content
VulnerabilityPublished

CVE-2026-115946: XS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds write

Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-115946· High

Not known to be exploited : upgrade to 1.2.1.0 soon.

Data as of 1 Nov 2026, 02:21 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 1.2.1.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade XS-libbrotli (Perl module) to 1.2.1.0.

Affected software

ProductAffectedFixed in
XS-libbrotliAffected
  • <1.2.1.0
Fixed in
  • 1.2.1.0
CPANXS-libbrotlipkg:cpan/XS-libbrotliOther threatsAffected
  • <1.2.1.0
Fixed in
  • 1.2.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade XS::libbrotli to version 1.2.1.0 or later, which includes an updated brotli library (version 1.2.1) that fixes the out-of-bounds write vulnerability. Note that upgrading the system brotli library alone does not mitigate this issue because XS::libbrotli statically links its own bundled brotli library.

Description

XS::libbrotli versions before 1.2.1.0 for Perl include a bundled brotli library with an out-of-bounds write vulnerability in the decoder. This flaw can be triggered by an attacker supplying a crafted brotli stream to any dependent module that decompresses untrusted data, potentially leading to memory corruption, information disclosure, process crashes, or arbitrary code execution. The vulnerability arises because the bundled brotli versions 1.0.7 or 1.1.0 contain the decoder flaw described in CVE-2026-111497. Upgrading the system brotli library does not mitigate this issue; only upgrading XS::libbrotli to version 1.2.1.0, which updates the bundled brotli to 1.2.1, resolves the vulnerability.

References

Community reviews

Loading reviews…