CVE-2024-51482: ZoneMinder v1.37. <= 1.37.64 is vulnerable to boolean-based SQL Injection in function of
Affects zoneminderSource GCVE Database
Not known to be exploited · public detection template (Nuclei) · CVSS 9.9 Critical · fixed in 1.37.65 : patch zoneminder as a priority.
Data as of 5 Nov 2026, 12:51 UTC
- Patch
- Available – fixed in 1.37.65
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2024
Detectable: evidence found.
nuclei template: ZoneMinder v1.37.* <= 1.37.64 - SQL Injection
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10zoneminderpkg:deb/ubuntu/zoneminder?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 25.10zoneminderpkg:deb/ubuntu/zoneminder?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSzoneminderpkg:deb/ubuntu/zoneminder?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSzoneminderpkg:deb/ubuntu/zoneminder?arch=source&distro=esm-apps/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ZoneMinder to version 1.37.65 or later to remediate this SQL Injection vulnerability. No other mitigations are indicated as the fix is available.
Description
ZoneMinder versions up to and including 1.37.64 contain a critical boolean-based SQL Injection vulnerability in the web/ajax/event.php function. This flaw allows an attacker with limited privileges to execute arbitrary SQL commands, potentially leading to full compromise of the application. The vulnerability is fixed in version 1.37.65.
References
- ubuntu.com/security/CVE-2024-51482 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-51482 (opens in a new tab)
- github.com/ZoneMinder/zoneminder/security/advisories/GHSA-qm8h-3xvf-m7j3 (opens in a new tab)
- github.com/ZoneMinder/zoneminder/commit/9e7d31841ed9678a7dd06869037686fc9925e59f (opens in a new tab)