A denial of service vulnerability exists in the .NET runtime cryptography layer affecting .NET 8, 9, and 10 on Linux and macOS platforms. The flaw occurs when parsing specially crafted X.509 certificates, potentially causing the application to crash or become unresponsive. This vulnerability is identified as CWE-843 (Access of Resource Using Incompatible Type).
A path traversal vulnerability in GitHub Enterprise Server allowed attackers with code execution inside the Dependabot updater container to write files to arbitrary repository paths, including GitHub Actions workflow files. This flaw enabled injection of malicious workflows that could execute with access to repository secrets if certain workflows or auto-merge were enabled. The vulnerability affects all versions prior to 3.22 and was fixed in versions 3.21.3, 3.20.5, 3.19.9, 3.18.12, and 3.17.18.
A heap buffer overflow vulnerability exists in libpng12's png_set_dither and png_set_quantize functions. This issue is addressed by a security update from the SUSE Product Security Team.
A security update for GnuTLS addresses multiple vulnerabilities including domain name acceptance errors due to case-sensitive comparisons, heap overread in RSA key exchange, name constraint bypasses, certificate validation bypasses with oversized SANs, use-after-free in PIN change operations, and memory corruption in PKCS#12 bag handling. These issues could lead to acceptance of invalid certificates, memory corruption, and potential denial of service or other impacts.
This security update for the TIFF image processing library addresses multiple vulnerabilities, including a heap-based buffer overflow (CVE-2026-12912) triggered by crafted PixarLog-compressed TIFF images and a denial of service (CVE-2026-36849) caused by TIFF files with large SamplesPerPixel tag values. The update also includes numerous bug fixes and improvements related to memory safety, integer overflow, and pointer dereferences.
This security update for GnuTLS addresses multiple vulnerabilities including excessive resource consumption, certificate validation bypasses, heap overreads and overwrites, integer overflow, denial of service, authentication bypass, use-after-free, and memory corruption. These issues affect certificate processing, DTLS handshake handling, PSK username processing, and PKCS#12 bag management.
A security update for the Postfix mail transfer agent addresses an unspecified issue. The update is provided by the SUSE Product Security Team. No specific details about the vulnerability or affected versions are disclosed.
js-toml versions up to and including 1.1.0 contain a vulnerability in the parsing of radix-prefixed integer literals (hexadecimal, octal, binary) where a quadratic time complexity in BigInt construction can cause CPU exhaustion. The parser's loop multiplies a BigInt accumulator by the radix for each digit, resulting in O(n²) complexity with respect to the literal length. There is no upper bound on the length of these literals, allowing an attacker to craft a single large literal (~500 kB) that can pin a CPU core for about 40 seconds, causing a denial of service. This affects any use of the load() function on attacker-controlled TOML input. The issue is fixed in version 1.1.2.
The go-chi/chi v5 middleware RealIP is vulnerable to IP spoofing because it trusts the first IP in the X-Forwarded-For header without verifying the proxy chain. This allows attackers to bypass IP-based access controls and rate limiting by spoofing their IP address. The vulnerability affects versions up to v5.2.1 and is fixed in v5.3.0.
Multiple security issues were addressed in the libssh2-1-1.11.1-3.1 package included in the GA media of openSUSE Tumbleweed. These fixes resolve vulnerabilities present in prior versions of the libssh2-1 library as maintained by the SUSE Product Security Team.
The undici WebSocket client is vulnerable to a denial of service caused by unbounded memory growth. This occurs because the client enforces a maximum cumulative payload size but does not limit the number of fragments in a WebSocket message. An attacker-controlled server can send many small or empty continuation frames, causing memory exhaustion in the client process. All undici versions starting from 6.17.0 up to but not including 6.27.0, versions from 7.0.0 up to but not including 7.28.0, and versions from 8.0.0 up to but not including 8.5.0 are affected. The issue is fixed in versions 6.27.0, 7.28.0, and 8.5.0. No workaround is available other than upgrading.
This security update for glibc addresses multiple vulnerabilities including a fix for ungetwc operating on byte streams (CVE-2026-5928), a buffer overflow in scanf %mc (CVE-2026-5450), and a character state handling issue in IBM1390 and IBM1399 character sets (CVE-2026-4046). These issues are resolved by the update provided by the SUSE Product Security Team.