Multiple security vulnerabilities have been identified and fixed in libssh2_org, including out-of-bounds heap reads, integer overflow, denial of service, heap buffer overflows, uninitialized pointer frees, arbitrary code execution, and information disclosure. These issues affect various functions such as sftp_symlink(), userauth_password(), SSH_MSG_EXT_INFO handler, publickey-subsystem response, and SSH negotiation processes.
Multiple security issues have been addressed in the libssh2-1-1.11.1-4.1 package available on the GA media of openSUSE Tumbleweed. These fixes pertain to vulnerabilities identified by several CVEs including CVE-2026-58050 and others. No detailed technical information or specific impacts are provided in the available data.
This security update for OpenSSH addresses multiple vulnerabilities including improper file location constraints in sftp downloads, directory traversal in scp between remote destinations, argument truncation in internal-sftp command lines, undocumented security behavior in Windows Active Directory GSSAPI, forwarding and tunneling configuration conflicts, pre-authentication denial of service via GSSAPI, authentication delay enforcement issues, and a client-side use-after-free during host key reexchange. These issues collectively pose risks such as unauthorized file placement, denial of service, and potential memory corruption.
A vulnerability in the Windows Machine Config Operator (WMCO) for Red Hat OpenShift Container Platform allows a compromised Windows worker node to escalate privileges to cluster-administrator level. The flaw involves improper validation of Certificate Signing Requests (CSRs), where additional organization values such as system:masters are not rejected, enabling privilege escalation. This affects OpenShift clusters running WMCO with Windows nodes. No mitigation or workaround is currently available, and a fix is expected in future updates.
An elevation of privilege vulnerability exists in Windows Presentation Foundation (WPF) in Microsoft .NET 8, 9, and 10 when parsing specially crafted XAML input. This vulnerability could allow an attacker to elevate privileges on the affected system. The issue is due to improper control of code generation (CWE-94). Affected package versions have been identified and patched in newer releases.
A security update for the SUSE Linux Enterprise 16.0 kernel addresses multiple security vulnerabilities across various kernel components. The update fixes issues including use-after-free, deadlocks, information leaks, infinite loops, and other bugs affecting networking, filesystems, Bluetooth, and more. These vulnerabilities have been assigned CVE identifiers and are resolved in the updated kernel version.
A denial of service vulnerability exists in the .NET HTTP client (System.Net.Http) affecting .NET versions 8, 9, and 10. The flaw allows an attacker to exploit the HTTP/2 protocol to cause an out-of-memory condition, leading to service disruption. This vulnerability is identified as CWE-770, involving allocation of resources without limits or throttling. Microsoft has released patches for affected versions to address this issue.
A denial of service vulnerability exists in Microsoft .NET TLS/SSL (System.Net.Security) affecting .NET versions 8, 9, and 10. An attacker can send a malformed TLS handshake request causing the application to crash or become unresponsive. This vulnerability is tracked as CVE-2026-50524 and has a CVSS 3.1 score of 7.5 (high severity).
A denial of service vulnerability exists in the .NET runtime cryptography layer affecting .NET 8, 9, and 10 on Linux and macOS platforms. The flaw occurs when parsing specially crafted X.509 certificates, potentially causing the application to crash or become unresponsive. This vulnerability is identified as CWE-843 (Access of Resource Using Incompatible Type).
A path traversal vulnerability in GitHub Enterprise Server allowed attackers with code execution inside the Dependabot updater container to write files to arbitrary repository paths, including GitHub Actions workflow files. This flaw enabled injection of malicious workflows that could execute with access to repository secrets if certain workflows or auto-merge were enabled. The vulnerability affects all versions prior to 3.22 and was fixed in versions 3.21.3, 3.20.5, 3.19.9, 3.18.12, and 3.17.18.
A heap buffer overflow vulnerability exists in libpng12's png_set_dither and png_set_quantize functions. This issue is addressed by a security update from the SUSE Product Security Team.
A security update for GnuTLS addresses multiple vulnerabilities including domain name acceptance errors due to case-sensitive comparisons, heap overread in RSA key exchange, name constraint bypasses, certificate validation bypasses with oversized SANs, use-after-free in PIN change operations, and memory corruption in PKCS#12 bag handling. These issues could lead to acceptance of invalid certificates, memory corruption, and potential denial of service or other impacts.