JupyterLab versions 4.5.9 and earlier, as well as versions 4.6.0 through 4.6.1, contain a vulnerability in the PyPIExtensionManager.install() method where a missing await causes the allowlist/blocklist enforcement to be bypassed for direct callers. This affects only custom extensions or downstream integrations that invoke install() directly with untrusted input. The standard JupyterLab HTTP API and UI are not affected. The issue is considered low impact and has been fixed in versions 4.5.10 and 4.6.2. Typical deployments using the HTTP API or UI require no action, and disabling programmatic extension installation via the read-only extension manager is a viable workaround.