A buffer overflow vulnerability exists in the Brotli decoder in Google Brotli versions 1.0.3 through 1.2.0. This flaw allows remote unauthenticated attackers to corrupt adjacent memory, potentially leading to sensitive data disclosure, denial of service, or arbitrary code execution. The vulnerability affects all platforms and requires updating to fixed versions 1.0.10, 1.1.1, or 1.2.1. The CVSS 4.0 score is 9.2, indicating critical severity.