Craft CMS versions from 4.5.0-beta.1 through 4.16.18 and 5.0.0-RC1 through 5.8.22 contain a stored cross-site scripting (XSS) vulnerability in the editableTable.twig component when using the 'Row Heading' column type. This vulnerability allows an attacker with administrator privileges and the allowAdminChanges setting enabled to inject arbitrary JavaScript code that executes when another user views the affected table field. The issue is fixed in versions 4.16.19 and 5.8.23.