Skip to main content
CVE-2026-93524VulnerabilityPublished

CheckKeySyms() · Buffer Overread

Source GCVE Database

0
Authoritative record:CVE-2026-93524· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 24.1.14 when convenient.

Data as of 28 Oct 2026, 19:43 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 21.1.25, 24.1.14
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade xwayland to 24.1.14; xorg-x11-server and freedesktop/xorg/xserver to 21.1.25.

Affected software

ProductAffectedFixed in
x.orgxorg-x11-serverAffected
  • <21.1.25
Fixed in
  • 21.1.25
x.orgxwaylandAffected
  • <24.1.14
Fixed in
  • 24.1.14
GitHubfreedesktop/xorg/xserverpkg:github/freedesktop/xorg/xserverOther threatsAffected
  • <21.1.25
Fixed in
  • 21.1.25

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in X.Org X Server version 21.1.25 and XWayland version 24.1.14. Users should upgrade to these or later versions to remediate the vulnerability. No other mitigations or workarounds are indicated. Since this is not a cloud service, remediation depends on applying the vendor's official patches.

Description

A buffer overread vulnerability exists in the CheckKeySyms() function of X.Org X Server versions before 21.1.25 and XWayland versions before 24.1.14. Authenticated X clients could exploit this flaw to leak small amounts of memory information or potentially cause the X server to crash.

References

Community reviews

Loading reviews…