Skip to main content
VulnerabilityPublished

CVE-2026-57185: asterisk · Buffer Over-read

Affects asteriskSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium · fixed in 23.4.1 : update asterisk when convenient.

Data as of 27 Oct 2026, 17:24 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 23.4.1, 22.10.1, 21.12.3 +3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
asteriskasteriskAffected
  • >=23.0.0-pre1 <23.4.1
Fixed in
  • 23.4.1
asteriskasteriskAffected
  • >=22.0.0-pre1 <22.10.1
Fixed in
  • 22.10.1
asteriskasteriskAffected
  • >=21.0.0-pre1 <21.12.3
Fixed in
  • 21.12.3
asteriskasteriskAffected
  • <20.20.1
Fixed in
  • 20.20.1
asteriskcertified-asteriskAffected
  • >=22.8-cert1-pre1 <22.8-cert3
Fixed in
  • 22.8-cert3
asteriskcertified-asteriskAffected
  • <20.7-cert11
Fixed in
  • 20.7-cert11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Asterisk to one of the fixed versions: 20.20.1, 21.12.3, 22.10.1, 23.4.1, or the corresponding Certified Asterisk releases 20.7-cert11 and 22.8-cert3. Applying these official fixes fully mitigates the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-57185 is a buffer over-read vulnerability in the PJSIP MWI body parser of Asterisk, an open source telephony toolkit. An authenticated attacker can cause a crash by sending a crafted SIP NOTIFY request. Authentication can be via username/password or source IP address matching. The issue affects multiple versions prior to fixed releases and has been addressed in Asterisk versions 20.20.1, 21.12.3, 22.10.1, 23.4.1, and corresponding Certified Asterisk releases.

References

Community reviews

Loading reviews…