Skip to main content
VulnerabilityPublished Updated

CVE-2025-54995: asterisk · Improper Validation of Syntactic Correctness of Input

Affects asteriskSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 18.26.4 or 18.9-cert17 when convenient.

Data as of 29 Oct 2026, 23:46 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.16.5
Patch
Available – fixed in 18.26.4, 18.9-cert17
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade asterisk to 18.26.4 or 18.9-cert17.

Affected software

ProductAffectedFixed in
asterisk asteriskAffected
  • <18.26.4
  • <18.9-cert17
Fixed in
  • 18.26.4
  • 18.9-cert17

AI-suggested

Upgrade Asterisk to version 18.26.4 or later, or 18.9-cert17 or later, where this issue has been fixed. No other mitigation is indicated or required as the fix addresses the root cause.

Description

CVE-2025-54995 affects Asterisk, an open source telephony toolkit, where prior to versions 18.26.4 and 18.9-cert17, improper session termination can cause RTP UDP ports and internal resources to leak. This leads to potential resource exhaustion. The issue has been addressed in the specified fixed versions.

References

Community reviews

Loading reviews…