Skip to main content
VulnerabilityPublished Updated

CVE-2025-47779: asterisk · Improper Neutralization of Delimiters

Affects asteriskSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.7 High · fixed in 22.4.1 : patch asterisk soon.

Data as of 30 Oct 2026, 00:18 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.7
Patch
Available – fixed in 22.4.1, 21.9.1, 20.14.1 +3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
asterisk asteriskAffected
  • <18.9-cert14
  • >=18.10 <18.26.2
  • >=20.0 <20.7-cert5
  • >=20.8 <20.14.1
  • >=21.0 <21.9.1
  • >=22.0 <22.4.1
Fixed in
  • 18.9-cert14
  • 18.26.2
  • 20.7-cert5
  • 20.14.1
  • 21.9.1
  • 22.4.1

AI-suggested

Apply the official fixes by upgrading to Asterisk versions 18.26.2, 20.14.1, 21.9.1, 22.4.1 or certified-asterisk versions 18.9-cert14 and 20.7-cert5. These versions address the vulnerability and prevent spoofing of user identities in SIP MESSAGE authentication. No additional mitigation is required beyond applying these patches.

Description

CVE-2025-47779 is a vulnerability in Asterisk PBX software affecting SIP MESSAGE request authentication prior to certain fixed versions. Authenticated attackers can spoof user identities to send spam messages appearing from trusted users, potentially enabling social engineering and phishing attacks. The issue is fixed in versions 18.26.2, 20.14.1, 21.9.1, 22.4.1, 18.9-cert14, and 20.7-cert5.

References

Community reviews

Loading reviews…