Skip to main content
VulnerabilityPublished Updated

CVE-2025-47780: asterisk · OS Command Injection

Affects asteriskSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.8 Medium · fixed in 22.4.1 : update asterisk when convenient.

Data as of 30 Oct 2026, 00:18 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.04.8
Patch
Available – fixed in 22.4.1, 21.9.1, 20.14.1 +3
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
asterisk asteriskAffected
  • <18.9-cert14
  • >=18.10 <18.26.2
  • >=20.0 <20.7-cert5
  • >=20.8 <20.14.1
  • >=21.0 <21.9.1
  • >=22.0 <22.4.1
Fixed in
  • 18.9-cert14
  • 18.26.2
  • 20.7-cert5
  • 20.14.1
  • 21.9.1
  • 22.4.1

AI-suggested

Upgrade Asterisk to one of the fixed versions: 18.26.2, 20.14.1, 21.9.1, 22.4.1 or certified-asterisk versions 18.9-cert14 or 20.7-cert5. Applying these official fixes will resolve the vulnerability. No other mitigation is indicated by the vendor advisory.

Description

CVE-2025-47780 is an OS command injection vulnerability in Asterisk PBX software where the cli_permissions.conf configuration intended to deny shell command execution via the CLI does not function correctly in affected versions. This flaw could allow an administrator who relies on cli_permissions.conf to be bypassed, potentially leading to unauthorized shell command execution. The issue is fixed in Asterisk versions 18.26.2, 20.14.1, 21.9.1, 22.4.1 and certified-asterisk versions 18.9-cert14 and 20.7-cert5.

References

Community reviews

Loading reviews…