Skip to main content
CVE-2024-52947VulnerabilityPublished Updated

LemonLDAP::NG · Cross-site Scripting (XSS) Vulnerability

Affects lemonldap-ngSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52947· Medium 6.1

Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.20.1 when convenient.

Data as of 29 Oct 2026, 23:00 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Affects
LemonLDAP::NG prior to 2.20.1
Patch
Available – fixed in 2.20.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade lemonldap-ng/lemonldap-ng to 2.20.1.

Affected software

ProductAffectedFixed in
GitHublemonldap-ng/lemonldap-ngpkg:github/lemonldap-ng/lemonldap-ngOther threatsAffected
  • <2.20.1
Fixed in
  • 2.20.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade LemonLDAP::NG to version 2.20.1 or later, where this vulnerability is fixed. If upgrading immediately is not possible, consider disabling the 'Upgrade session' plugin to mitigate the risk. No other vendor advisories indicate alternative mitigations or that no action is required.

Description

A cross-site scripting (XSS) vulnerability exists in LemonLDAP::NG versions prior to 2.20.1. This flaw allows remote attackers to inject arbitrary web script or HTML via the url parameter on the upgrade session confirmation page if the 'Upgrade session' plugin is enabled by an administrator. The vulnerability has been assigned CVE-2024-52947 and has a medium severity rating.

References

Community reviews

Loading reviews…