Skip to main content
VulnerabilityPublished

CVE-2026-105481: node

Affects nodeSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-105481· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in 26.12.1 : update node when convenient.

Data as of 29 Oct 2026, 13:20 UTC

CVSS 3.0 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (hackerone)CVSS 3.06.5
Patch
Available – fixed in 26.12.1, 24.22.1, 22.23.4
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade node to 26.12.1, 24.22.1 or 22.23.4.

Affected software

ProductAffectedFixed in
Bitnaminodepkg:bitnami/nodeOther threatsAffected
  • <22.23.4
  • >=23.0.0 <24.22.1
  • >=25.0.0 <26.12.1
Fixed in
  • 22.23.4
  • 24.22.1
  • 26.12.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in Node.js versions 22.23.4, 24.22.1, and 26.12.1. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated.

Description

A flaw in Node.js HTTP Agent connection reuse allows a client to accept a response sent before the client has sent the request. This occurs because the guard that destroys idle keep-alive sockets on unexpected data only runs when the event loop polls for I/O, and unsolicited responses may be misinterpreted as valid responses to new requests. This vulnerability affects Node.js versions 22.x, 24.x, and 26.x and is a partial regression of a previous flaw (CVE-2026-48931).

References

Community reviews

Loading reviews…