Skip to main content
VulnerabilityPublished

CVE-2026-122158: InvoiceShelf · CWE-266

Affects InvoiceShelfSource GCVE Database

0
Compare
Authoritative record:CVE-2026-122158· Medium 5.1

Public exploit available · CVSS 5.1 Medium : upgrade to 3.0.0-alpha.4 or 2.4.4 as a priority.

Data as of 5 Nov 2026, 04:29 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.1
CNA (VulDB)CVSS 3.14.7
CNA (VulDB)CVSS 3.04.7
CNA (VulDB)CVSS 2.05.8
Affects
InvoiceShelf up to 2.4.3
Patch
Available – fixed in 3.0.0-alpha.4, 2.4.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade invoiceshelf/InvoiceShelf to 3.0.0-alpha.4 or 2.4.4.

Affected software

ProductAffectedFixed in
GitHubinvoiceshelf/InvoiceShelfpkg:github/invoiceshelf/InvoiceShelfOther threatsAffected
  • <2.4.4
  • >=3.0.0-alpha.0 <3.0.0-alpha.4
Fixed in
  • 2.4.4
  • 3.0.0-alpha.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade InvoiceShelf to version 2.4.4 or 3.0.0-alpha.4, where the vulnerability is patched. Applying the patch identified by commit c798b513c3ab6e672a1678774720fbb282f4d0c6 fully resolves the issue. No other mitigations are indicated.

Description

A security flaw in InvoiceShelf versions up to 2.4.3 and 3.0.0-alpha.3 allows improper access control due to manipulation of the companies[].id and companies[].role arguments in the MemberService::create function. This vulnerability can be exploited remotely and public exploit code is available. Upgrading to versions 2.4.4 or 3.0.0-alpha.4 resolves the issue.

References

Community reviews

Loading reviews…