Skip to main content
VulnerabilityPublished Updated

CVE-2026-12261: Gptline · NLTK downloader allows cross-package resource and model poisoning

Affects gptlineSource GCVE Database

0
Compare
Authoritative record:CVE-2026-12261· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.0.8_22 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.10.0, 3.8.1_1, 1.0.8_22
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade gptline to 1.0.8_22; nltk to 3.10.0; safety to 3.8.1_1.

Affected software

ProductAffectedFixed in
PyPInltkpkg:pypi/nltkOther threatsAffected
  • <=3.9.4
Fixed in–
PyPInltkAffected
  • <3.10.0
Fixed in
  • 3.10.0
Homebrewsafetypkg:brew/safetyOther threatsAffected
  • >=3.3.1 <3.8.1_1
Fixed in
  • 3.8.1_1
Homebrewgptlinepkg:brew/gptlineOther threatsAffected
  • >=1.0.8 <1.0.8_22
Fixed in
  • 1.0.8_22

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade to a fixed version of nltk beyond 3.9.4 and 3.10.0 to prevent cross-package resource poisoning. Until patched, avoid installing untrusted packages via nltk.downloader and consider isolating environments to limit impact. Check the official vendor advisory for specific fixed versions and update instructions.

Description

A vulnerability in `nltk.downloader` in nltk/nltk versions <= 3.9.4 allows for cross-package resource and model poisoning. The downloader extracts package archives into shared namespaces such as `corpora/` and `taggers/` instead of package-isolated roots, and validates package integrity only after the archive has been written and extracted. This design flaw enables one package to overwrite another package's trusted resources within the same namespace, making the changes immediately active through ordinary NLTK APIs. This issue persists across fresh interpreter restarts and can affect downstream workflows, including machine learning pipelines and reproducibility-sensitive environments.

References

Community reviews

Loading reviews…