Skip to main content
VulnerabilityPublished

CVE-2026-92993: Dromara mayfly-go · Command Injection

Affects mayfly-goSource GCVE Database

0
Compare
Authoritative record:CVE-2026-92993· Medium 5.3

Public exploit available · CVSS 5.3 Medium : upgrade to 1.11.6 as a priority.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.4% chance of exploitation in 30 days – higher than 73% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade dromara/mayfly-go to 1.11.6.

Affected software

ProductAffectedFixed in
GitHubdromara/mayfly-gopkg:github/dromara/mayfly-goOther threatsAffected
  • <1.11.6
Fixed in
  • 1.11.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict the machine:script:run permission and tag access to trusted users only. Monitor for suspicious command execution activity related to machine scripts. Since the vendor has not responded, consider additional network-level controls to limit exposure.

Description

A command injection vulnerability exists in Dromara mayfly-go up to version 1.11.5 in the RunMachineScript function of the Machine Script Feature. This vulnerability allows remote attackers with the machine:script:run permission and tag access to execute arbitrary OS commands on machines with vulnerable templates. The exploit does not require an admin account and leverages unfiltered input in the SSH exec layer. The vendor has not responded to disclosure attempts. The vulnerability has a CVSS score of 6.3, indicating a medium severity level.

References

Community reviews

Loading reviews…