Skip to main content
VulnerabilityPublished

CVE-2026-92992: Dromara mayfly-go · Missing Authorization

Affects mayfly-goSource GCVE Database

0
Compare
Authoritative record:CVE-2026-92992· Medium 5.3

Public exploit available · CVSS 5.3 Medium : upgrade to 1.11.6 as a priority.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade dromara/mayfly-go to 1.11.6.

Affected software

ProductAffectedFixed in
GitHubdromara/mayfly-gopkg:github/dromara/mayfly-goOther threatsAffected
  • <1.11.6
Fixed in
  • 1.11.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch has been applied to fix this vulnerability as indicated by the silent patch commit 74bcb926eb4f5f94e7681144d7bf2168a0ec7cde. Users should apply this patch to remediate the issue. Since the patch is available, no additional mitigation steps are required beyond updating to the fixed version.

Description

A security vulnerability (CVE-2026-92992) exists in Dromara mayfly-go up to version 1.11.5 in the AI Assistant component. The flaw involves missing authorization in an unknown function within the file server/internal/ai/api/ai.go. This vulnerability allows remote exploitation and involves a whitelist bypass that lets certain commands run without explicit approval. The issue has been fixed with a silent patch identified by commit 74bcb926eb4f5f94e7681144d7bf2168a0ec7cde.

References

Community reviews

Loading reviews…