CVE-2026-82558: Apache Wicket · Missing Authorization
Affects Apache WicketSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low · fixed in 8.20.0 : update Apache Wicket when convenient.
Data as of 1 Nov 2026, 22:28 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 2.3 |
|---|
- Patch
- Available – fixed in 8.20.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Wicketorg.apache.wicket:wicket-native-websocket-core | Affected
| Fixed in– |
Mavenorg.apache.wicket/wicket-native-websocket-corepkg:maven/org.apache.wicket/wicket-native-websocket-coreOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 or later, where this missing authorization issue is fixed. No other mitigation is indicated or required by the vendor advisory.
Description
CVE-2026-82558 is a missing authorization vulnerability in Apache Wicket's WebSocketBehavior component. The issue arises because WebSocketBehavior does not verify if a client is authorized to invoke the component it is attached to before calling onMessage() callbacks. This contrasts with Ajax behaviors, which perform authorization checks. The vulnerability affects Apache Wicket versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0. Fixed versions are 8.20.0, 9.25.0, and 10.12.0. Exploitation requires the client to have their own session and page containing the affected component, limiting cross-user impact. Server-pushed messages are not affected.