CVE-2026-112375: Apache Kafka · Missing Authorization
Affects Apache KafkaSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · fixed in 4.2.2 : patch Apache Kafka soon.
Data as of 28 Oct 2026, 17:23 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
- Patch
- Available – fixed in 4.2.2
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Kafkaorg.apache.kafka:kafka | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.kafka:kafkapkg:maven/Apache Software Foundation/org.apache.kafka:kafkaOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Kafka to versions 4.2.2, 4.3.2, or 4.4.0 where authorization checks (ALTER_CONFIGS) are enforced before configuration validation and config-provider resolution is restricted to an allowlist. Additionally, run Kafka brokers under least-privileged operating system accounts to limit file access by the broker process and reduce exposure of sensitive files.
Description
CVE-2026-112375 is a missing authorization vulnerability in Apache Kafka that allows an authenticated principal without any authorization grants to read files or environment variables from the broker host. This occurs because configuration validation happens before authorization checks, enabling resolution of configuration variables that expose sensitive data. The issue affects Kafka versions from 3.2.0 through 4.1.2, 4.2.0 through 4.2.1, and 4.3.0 through 4.3.1. The vulnerability is mitigated in versions 4.2.2, 4.3.2, and 4.4.0 by enforcing authorization before configuration validation and restricting config-provider usage. Running brokers under least-privileged OS accounts is recommended as additional defense.