Skip to main content
VulnerabilityPublished

CVE-2026-82704: Apache Wicket · Missing Authorization

Affects Apache WicketSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium · fixed in 8.20.0 : update Apache Wicket when convenient.

Data as of 1 Nov 2026, 22:30 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.06.9
Patch
Available – fixed in 8.20.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Wicketorg.apache.wicket:wicket-coreAffected
  • >=8.0.0 <=8.19.0
  • >=9.0.0 <=9.24.0
  • >=10.0.0 <=10.11.0
Fixed in–
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threatsAffected
  • >=8.0.0 <=8.19.0
  • >=9.0.0 <=9.24.0
  • >=10.0.0 <=10.11.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 or later, where this vulnerability is fixed. No other mitigations are indicated or recommended by the vendor advisory. Applications relying on component-level authorization should prioritize patching to ensure proper enforcement of render restrictions.

Description

CVE-2026-82704 is a missing authorization vulnerability in Apache Wicket affecting versions 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0. The flaw allows unauthorized invocation of component listeners when a listener URL omits the page identifier, causing the authorization checks to be bypassed. This affects applications that restrict component rendering via IAuthorizationStrategy or Component#onConfigure(). The issue is fixed in Apache Wicket versions 8.20.0, 9.25.0, and 10.12.0.

References

Community reviews

Loading reviews…