Skip to main content
VulnerabilityPublished

CVE-2026-122015: NPC-Worldwide npcpy · Improper Input Validation

Affects npcpySource GCVE Database

0
Compare
Authoritative record:CVE-2026-122015· Medium 5.3

Public exploit available · CVSS 5.3 Medium : upgrade to 2.1.28 as a priority.

Data as of 5 Nov 2026, 01:30 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.3
CNA (VulDB)CVSS 3.16.3
CNA (VulDB)CVSS 3.06.3
CNA (VulDB)CVSS 2.07.5
Affects
NPC-Worldwide npcpy up to 2.1.27
Patch
Available – fixed in 2.1.28
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade npc-worldwide/npcpy to 2.1.28.

Affected software

ProductAffectedFixed in
GitHubnpc-worldwide/npcpypkg:github/npc-worldwide/npcpyOther threatsAffected
  • <2.1.28
Fixed in
  • 2.1.28

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A vulnerability in NPC-Worldwide npcpy up to version 2.1.27 affects the get_mlx_response function in the MLX Provider component. The flaw involves improper input validation of the 'model' argument, which can be exploited remotely. Public exploit code is available. The CVSS score is 6.3, indicating a medium severity impact.

References

Community reviews

Loading reviews…