Skip to main content
VulnerabilityPublished

CVE-2026-59978: AdminNeo · version-cache array injection causes persistent denial of service

Affects adminneo-org/adminneoSource GCVE Database

0
Compare
Authoritative record:CVE-2026-59978· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.5.0 soon.

Data as of 30 Oct 2026, 20:35 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 5.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade adminneo-org/adminneo to 5.5.0.

Affected software

ProductAffectedFixed in
Packagistadminneo-org/adminneoAffected
  • >=4.6.2 <5.5.0
Fixed in
  • 5.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official fix is available in AdminNeo version 5.5.0. Users should upgrade to this version to resolve the vulnerability. As a workaround, if upgrading is not immediately possible, make the `adminneo.version` file in the temporary directory unwritable by the web server to prevent caching of malicious input. Manual deletion of the poisoned cache file (`/tmp/adminneo.version`) also restores service. No other actions are required.

Description

AdminNeo versions from 4.6.2 up to but not including 5.5.0 have a vulnerability in the `?script=version` endpoint that allows an attacker to cause a persistent denial of service. The endpoint accepts POST requests without origin or type validation, allowing an attacker to send a `version[]` parameter that PHP interprets as an array. This causes a type error in the server's cookie-setting function, resulting in HTTP 500 errors for all users for up to 24 hours until the cached version file expires or is deleted.

References

Community reviews

Loading reviews…