Skip to main content
VulnerabilityPublished Updated

CVE-2024-45237: Fort · Buffer Overflow

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-45237· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 1.6.3 : patch Fort as a priority.

Data as of 30 Oct 2026, 00:38 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Affects
Fort before 1.6.3
Patch
Available – fixed in 1.6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

A fix is available in Fort version 1.6.3. Users should upgrade to version 1.6.3 or later to remediate this vulnerability. No other mitigation or workaround is indicated.

Description

CVE-2024-45237 is a critical buffer overflow vulnerability in Fort versions before 1.6.3. It arises when a malicious RPKI repository, trusted via a Trust Anchor, serves a resource certificate with a Key Usage extension exceeding two bytes. Fort improperly writes this extension into a fixed 2-byte buffer without length validation, causing a buffer overflow.

References

Community reviews

Loading reviews…