Skip to main content
VulnerabilityPublished

CVE-2026-44092: An unauthenticated remote attacker can inject malicious input into the ModbusServer application because it does not validate the input it fetches

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-44092· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 1.9.1 soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade CHARX to 1.9.1.

Affected software

ProductAffectedFixed in
Phoenix ContactCHARX SEC-3150Affected
  • >=1.0.0 <1.9.1
Fixed in
  • 1.9.1
Phoenix ContactCHARX SEC-3100Affected
  • >=1.0.0 <1.9.1
Fixed in
  • 1.9.1
Phoenix ContactCHARX SEC-3050Affected
  • >=1.0.0 <1.9.1
Fixed in
  • 1.9.1
Phoenix ContactCHARX SEC-3000Affected
  • >=1.0.0 <1.9.1
Fixed in
  • 1.9.1

AI-suggested

If you cannot patch yet, organizations should consider network-level controls to restrict access to the ModbusServer application and monitor for unusual activity related to Modbus communications.

Description

CVE-2026-44092 is a high-severity vulnerability affecting Phoenix Contact CHARX SEC-3150 devices. It allows an unauthenticated remote attacker to inject malicious input into the ModbusServer application due to lack of input validation. This vulnerability enables network-adjacent attackers to bypass firewall rules without requiring authentication.

References

Community reviews

Loading reviews…