Skip to main content
VulnerabilityPublished Updated

CVE-2026-30922: Ansible · Denial of Service in pyasn1 via Unbounded Recursion

Affects ansibleSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 13.4.0_1 soon.

Data as of 1 Nov 2026, 02:05 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 13.4.0_1
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Description

The pyasn1 library used in Ansible is vulnerable to a Denial of Service (DoS) attack due to unbounded recursion when decoding ASN.1 data with deeply nested indefinite-length SEQUENCE or SET tags. An attacker can craft a payload that causes the decoder to recursively call itself until the Python interpreter crashes with a RecursionError or the system runs out of memory, resulting in service disruption. This affects versions from 1.7.2 up to but not including 13.4.0_1. A fix is available in version 13.4.0_1.

References

Community reviews

Loading reviews…