Skip to main content
VulnerabilityPublished Updated

CVE-2026-57585: MessagePack for Python · Out-of-bounds read / crash on Unpacker reuse after a caught error

Affects ansibleSource GCVE Database

0
Compare
Authoritative record:CVE-2026-57585· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 14.0.0_2 soon.

Data as of 1 Nov 2026, 02:06 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 14.0.0_2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade ansible to 14.0.0_2.

Affected software

ProductAffectedFixed in
Homebrewansiblepkg:brew/ansibleOther threatsAffected
  • >=2.5.0 <14.0.0_2
Fixed in
  • 14.0.0_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in version 14.0.0_2 that prevents the segmentation fault crash. Users should upgrade to this version to remediate the vulnerability. Additionally, the recommended practice is to discard the Streaming Unpacker and the associated stream after an error occurs and create a new Unpacker instance rather than reusing the existing one. This approach prevents both crashes and incorrect data processing. The patch prevents crashes from incorrect usage but does not replace the need for this correct usage pattern.

Description

MessagePack for Python contains a vulnerability (CVE-2026-57585) where reusing the Unpacker object after an error can cause an out-of-bounds read leading to a segmentation fault (SEGV) crash. This can result in a denial-of-service (DoS) condition if untrusted input triggers repeated errors. The issue is fixed in version 14.0.0_2. Users are advised to create a new Unpacker instance after an error instead of reusing the same one to avoid crashes and incorrect data processing.

References

Community reviews

Loading reviews…