Skip to main content
VulnerabilityPublished

CVE-2024-23334: Apache superset · aiohttp is an asynchronous HTTP client/server framework for asyncio and Python

Affects apache-supersetSource GCVE Database

0
Compare
Authoritative record:CVE-2024-23334· Medium 5.9

Public exploit available (Exploit-DB) · CVSS 5.9 Medium : upgrade to 2021.36.5-r0 as a priority.

Data as of 5 Nov 2026, 02:11 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2021.36.5-r0, 2021.38.2-r0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  3. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitHub, Inc.

    , 1.4 years before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 1 minute after disclosure

  4. First Exploit-DB entry (opens in a new tab)

    aiohttp 3.9.1 - directory traversal PoC

    , 250 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache-superset to 2021.36.5-r0; apache-superset to 2021.38.2-r0.

Affected software

ProductAffectedFixed in
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <2021.36.5-r0
Fixed in
  • 2021.36.5-r0
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <2021.38.2-r0
Fixed in
  • 2021.38.2-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading apache-superset to version 2021.36.5-r0 or 2021.38.2-r0 or later. No other mitigation steps are indicated by the vendor advisory. Since public exploit code exists, timely patching is recommended.

Description

CVE-2024-23334 is a high-severity security vulnerability affecting the apache-superset package, related to the aiohttp asynchronous HTTP client/server framework for asyncio and Python. The vulnerability allows remote network attackers to cause a high impact on confidentiality without requiring privileges or user interaction. Fixed versions 2021.36.5-r0 and 2021.38.2-r0 address this issue.

References

Community reviews

Loading reviews…