Skip to main content
VulnerabilityPublished

CVE-2024-30251: Apache superset · aiohttp is an asynchronous HTTP client/server framework for asyncio and Python

Affects apache-supersetSource GCVE Database

0
Compare
Authoritative record:CVE-2024-30251· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 2021.38.2-r0 soon.

Data as of 5 Nov 2026, 02:11 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 2021.38.2-r0, 2021.36.5-r0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache-superset to 2021.38.2-r0; apache-superset to 2021.36.5-r0.

Affected software

ProductAffectedFixed in
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <2021.38.2-r0
Fixed in
  • 2021.38.2-r0
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <2021.36.5-r0
Fixed in
  • 2021.36.5-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading apache-superset to version 2021.38.2-r0 or 2021.36.5-r0 or later. Since a patch is available, remediation should be performed promptly to prevent potential denial of service.

Description

CVE-2024-30251 is a high-severity security vulnerability affecting the apache-superset package, related to the aiohttp asynchronous HTTP client/server framework used in Python. The flaw impacts versions prior to 2021.38.2-r0 and 2021.36.5-r0. It does not affect confidentiality or integrity but causes a high impact on availability. A patch is available in versions 2021.38.2-r0 and 2021.36.5-r0.

References

Community reviews

Loading reviews…