CVE-2026-69244: Apache superset · AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python
Affects apache-supersetSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2021.36.5-r0 soon.
Data as of 5 Nov 2026, 02:01 UTC
- Patch
- Available – fixed in 2021.36.5-r0, 2021.38.2-r0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade apache-superset to 2021.36.5-r0; apache-superset to 2021.38.2-r0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threats | Affected
| Fixed in
|
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade apache-superset to version 2021.36.5-r0 or later, or 2021.38.2-r0 or later, where this vulnerability has been fixed. Applying these official patches fully mitigates the issue.
Description
A high-severity security vulnerability (CVE-2026-69244) affects the apache-superset package, related to the AIOHTTP asynchronous HTTP client/server framework for asyncio and Python. Versions prior to 2021.36.5-r0 and 2021.38.2-r0 are impacted. A fix is available in these versions.