Skip to main content
VulnerabilityPublished

CVE-2026-112909: Apache superset · filelock is a platform-independent file lock for Python

Affects apache-supersetSource GCVE Database

0
Compare
Authoritative record:CVE-2026-112909· Medium 6.1

Not known to be exploited · CVSS 6.1 Medium : upgrade to 6.1.0-r8 when convenient.

Data as of 5 Nov 2026, 02:00 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.16.1
Patch
Available – fixed in 6.1.0-r8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache-superset to 6.1.0-r8.

Affected software

ProductAffectedFixed in
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <6.1.0-r8
Fixed in
  • 6.1.0-r8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in apache-superset version 6.1.0-r8. Users should upgrade to this version or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

A security vulnerability has been identified in the apache-superset package related to the filelock component, which is a platform-independent file lock for Python. Versions prior to 6.1.0-r8 are affected. The vulnerability has a CVSS 3.1 base score of 6.1, indicating a medium severity issue. It involves a local attack vector with low complexity and requires low privileges but no user interaction. The impact includes low confidentiality, high integrity impact, and no availability impact. A patch is available in version 6.1.0-r8.

References

Community reviews

Loading reviews…