Skip to main content
VulnerabilityPublished

CVE-2026-112398: Apache superset · Pillow is a Python imaging library

Affects apache-supersetSource GCVE Database

0
Compare
Authoritative record:CVE-2026-112398· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical : upgrade to 2021.36.5-r0 as a priority.

Data as of 5 Nov 2026, 02:11 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.09.2
Patch
Available – fixed in 2021.36.5-r0, 2021.38.2-r0
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache-superset to 2021.36.5-r0; apache-superset to 2021.38.2-r0.

Affected software

ProductAffectedFixed in
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <2021.36.5-r0
Fixed in
  • 2021.36.5-r0
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <2021.38.2-r0
Fixed in
  • 2021.38.2-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading apache-superset to versions 2021.36.5-r0 or 2021.38.2-r0 or later. Since a patch is available, remediation should be prioritized to mitigate the critical risk posed by this vulnerability.

Description

A critical security vulnerability (CVE-2026-112398) affects the apache-superset package due to an issue in the Pillow Python imaging library. The flaw has a high CVSS score of 9.8, indicating severe impact on confidentiality, integrity, and availability. Fixed versions 2021.36.5-r0 and 2021.38.2-r0 are available to remediate the issue.

References

Community reviews

Loading reviews…