Skip to main content
VulnerabilityPublished

CVE-2026-96639: Apache superset · Pillow is a Python imaging library

Affects apache-supersetSource GCVE Database

0
Compare
Authoritative record:CVE-2026-96639· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 2021.36.5-r0 as a priority.

Data as of 5 Nov 2026, 02:01 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.19.8
Patch
Available – fixed in 2021.36.5-r0, 2021.38.2-r0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache-superset to 2021.36.5-r0; apache-superset to 2021.38.2-r0.

Affected software

ProductAffectedFixed in
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <2021.36.5-r0
Fixed in
  • 2021.36.5-r0
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <2021.38.2-r0
Fixed in
  • 2021.38.2-r0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading apache-superset to version 2021.36.5-r0 or later, or 2021.38.2-r0 or later. Since patches are available, remediation should focus on timely updating to these fixed versions to eliminate the vulnerability.

Description

A critical security vulnerability (CVE-2026-96639) affects the apache-superset package due to an issue in the Pillow Python imaging library. The flaw impacts versions of apache-superset prior to 2021.36.5-r0 and 2021.38.2-r0. The vulnerability has a high CVSS score of 9.8, indicating severe potential impact on confidentiality, integrity, and availability. Fixed versions are available, and patches should be applied to mitigate the risk.

References

Community reviews

Loading reviews…