Skip to main content
VulnerabilityPublished Updated

CVE-2026-41636: Apache Thrift Node.js bindings vulnerable to Uncontrolled Recursion

Affects thriftSource GCVE Database

0
Authoritative record:CVE-2026-41636· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 0.23.0 soon.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.23.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade thrift to 0.23.0.

Affected software

ProductAffectedFixed in
npmthriftAffected
  • <0.23.0
Fixed in
  • 0.23.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

References

Community reviews

Loading reviews…